top of page

Test Excel : Corrigé thème 2


Nous vous proposons un article de comprendre les bases d'Excel pour un niveau intermédiaire et apporter les réponses à notre questionnaire principal.


PowerBi

Question :

Thème 2 : Fonctions de base et logique


Question 1 : Pour lier les valeurs de deux cellules qui contient du texte, que doit-on utiliser ?

Nous sommes très surpris de voir le nombre de mauvaises réponses à cette question.

Pour lier les valeurs de deux cellules qui contiennent du texte dans Excel, vous pouvez utiliser la fonction CONCATENER ou l'opérateur "&".


Ce qui vous perturbe, est peut-être le format [@NOM...] par exemple. Ceci est l'écriture lorsque vous travaillez en mise en forme sous tableau. Ce sont pourtant les nouvelles méthodes lorsque vous travaillez sous Excel.

C'est un outil de mise en forme et de structuration de données dans Excel. Elle permet de convertir un ensemble de données en tableau organisé et facile à lire.


Réponse : l'opérateur "&"


Voici divers avantages que vous avez à utiliser la mise en forme sous tableau

  1. Structuration des données : La mise en forme sous tableau permet de structurer les données en les organisant en colonnes et en lignes. Cela facilite la lecture des données et leur compréhension.

  2. Tri et filtres : Avec la mise en forme sous tableau, il est facile de trier et de filtrer les données selon des critères spécifiques, en utilisant les outils de tri et de filtre intégrés dans Excel.

  3. Calculs et totaux automatiques : La mise en forme sous tableau permet également de faire des calculs automatiques sur les données, comme le calcul de la moyenne, de la somme ou du nombre d'éléments dans une colonne. Ces calculs sont mis à jour automatiquement lorsque de nouvelles données sont ajoutées.

  4. Mise en forme automatique : La mise en forme sous tableau inclut des styles de tableau prédéfinis, qui permettent d'appliquer rapidement une mise en forme cohérente à l'ensemble du tableau.

  5. Dynamisme : Les tableaux Excel sont dynamiques, ce qui signifie que lorsqu'une donnée est ajoutée ou supprimée, le tableau est automatiquement mis à jour pour refléter ces changements.



Question 2 : La syntaxe est-elle correcte ?


Un nom de plage dans Excel est un alias ou un identificateur symbolique pour une plage de cellules. Il permet de référencer plus facilement une plage de données dans une formule, une fonction ou une macro. Au lieu d'utiliser des références de cellules (comme C2:C6), vous pouvez utiliser un nom de plage (comme "PlageN") pour référencer la plage de données.


Réponse : Oui, mais la formule fonctionnera seulement si une plage de données s'appelle "PlageN"


Voici quelques avantages de l'utilisation de noms de plage dans Excel :

  • Facilité de lecture et de compréhension : En utilisant un nom de plage, vous pouvez rendre les formules et les fonctions plus faciles à lire et à comprendre, en utilisant un nom qui décrit la plage de données plutôt que des références de cellules.

  • Réutilisation des formules : En utilisant un nom de plage, vous pouvez aisément réutiliser une formule sur différentes plages de données sans avoir à modifier les références de cellules à chaque fois.

  • Flexibilité : Les noms de plage peuvent être utilisés dans des fonctions de tableaux, telles que SOMME, MOYENNE et MAX, pour effectuer des calculs sur des plages de données de manière flexible.


Pour créer un nom de plage dans Excel, vous pouvez sélectionner la plage de cellules que vous souhaitez nommer, puis cliquer sur la barre de formule en haut de la feuille de calcul et saisir un nom pour la plage. Vous pouvez également créer et gérer des noms de plage dans le Gestionnaire de noms, accessible à partir du ruban Excel.




Question 3 : Écrivez la fonction"=SI("suivante : Si en cellule F2, il est inscrit le mot Homme alors inscrire oui sinon inscrire non

La fonction SI est l'une des fonctions les plus utilisées dans Microsoft Excel. Elle permet de réaliser des calculs conditionnels en évaluant une condition et en retournant une valeur si la condition est vraie, et une autre valeur si la condition est fausse.

Si vous savez utiliser correctement la fonction SI nous estimons alors que vous avez un niveau intermédiaire en Excel.


La fonction Si à trois parties ou trois paramètres, ces paramètres sont séparés par des point-virgules ";" et dont l'ordre est invariable.

=SI(condition ; résultat si la condition est vraie ; résultat si la condition est fausse)


condition : Vous souhaitez savoir s'il y a écrit le mot "Homme" dans la cellule F2, vous l'écrirez comme ceci F2="Homme . Avec la fonction SI cela donnera "=SI(F2=homme..."

Lisez cela à haute voix et la condition vous paraitra plus logique :)


Ensuite : si cette condition est vérifiée (ou vraie) alors inscrire "oui" sinon inscrire "non".

La réponse est : =SI(F2="Homme";"oui";"non")


Pour information, nous avons accepté les réponses si vous avez écrit en minuscule la formule. Par contre "Homme" doit être écrit avec un H majuscule.




Question 4 : Que donnera la cellule J2 ?

=SI(H2<=100;I2;"N/A")

Si vous avez bien suivi la réponse précédente, il suffi de vérifier la condition pour connaitre la bonne réponse. La cellule H2 est-elle inférieure ou égale à 100 ? En cellule H2, vous avez le chiffre 50.

Cela revient à dire : le chiffre cinquante est-il inférieur ou égal au chiffre cent ? (50 <=100 ?) la réponse est oui (cette condition est vraie)

Si la condition est vraie, alors la réponse est le 2ᵉ paramètre de la formule est la cellule I2.

En cellule I2, vous avez le chiffre 200.

La formule va vous renvoyer la réponse : 200




Question 5 :

Nous essayons de savoir ici si vous savez utiliser la fonction ET avec la fonction SI.


Voici votre formule :

=SI(ET(H2<=100;I2="ok");"FAUX";"VRAI")


Vous avez ici une formule avec la condition suivante : (ET(H2<=100;I2="ok").

Vous avez la fonction "ET" qui entre en compte.

La fonction ET renvoie "VRAI" UNIQUEMENT si chacune des parties de la condition sont les vraies.

Ici, il y a 2 questions :

  1. H2 <= 100 ? Or la cellule H2 = 50. Cela revient à dire 50 < 100 ? --> c'est vrai

  2. I2 = "ok" ? I2 contient le mot "ok" --> c'est vrai

Si la condition est vraie, alors la réponse est le 2ᵉ paramètre de la formule qui est le texte "FAUX".

La formule va vous renvoyer la réponse : "FAUX".




Question 6 :


Nous essayons de savoir ici si vous savez utiliser la fonction SI avec une autre fonction SI : ce sont les formules SI imbriquées)

Durant votre carrière, vous allez souvent rencontrer des formules Si imbriquées, nous conseillons quand même de limiter leurs utilisations, car cela devient vite illisible.


Voici votre formule :

=SI(H2>=100;SI(1000>I2;"OUI";"NON");"PAS OK")


La réponse d'une formule SI est une autre formule SI.

La première formule SI est la suivante

=SI(H2>=100;SI(1000>I2;"OUI";"NON");"PAS OK")


H2 à le chiffre 101. 101> 100 --> C'est vrai alors la réponse de cette formule si est la deuxième formule Si : SI(1000>IZ;"OUI";"NON")


Deuxième formule si :

SI(1000>I2;"OUI";"NON")

1000 > I2 ? --> 1000 > 300 ? --> C'est vrai

La réponse est alors OUI




Question 7 : Observez la cellule avec le $. Je souhaite faire un glisser copier vers ma cellule suivante (de F2 à F3), que va-t-il s'inscrire en F3 ?


Il est question ici des références de cellules

  • Relatives

  • Absolues ($A$1)

  • Mixte (A$1 ou $A1 )


Les références de cellules (= coordonnée d'une cellule) peuvent être de trois types différents : relatives, absolues ou mixtes. La différence entre ces types de références est importante, car elle affecte la façon dont les formules sont copiées ou déplacées dans une feuille de calcul.


Une référence de cellule relative est une référence qui change automatiquement en fonction de la position de la formule lorsqu'elle est copiée ou déplacée dans une feuille de calcul. Par exemple, si vous avez une formule qui fait référence à la cellule A1 et que vous la copiez dans la cellule B1, la référence de cellule sera automatiquement mise à jour pour faire référence à la cellule B1.


La référence absolue est reconnaissable par son symbole unique : "$". Le $ permet de bloquer une ligne, une colonne ou les deux. Il s'écrit dans la ligne ou la colonne.

Par exemple, si vous voulez que la référence de cellule A1 reste constante lorsqu'elle est copiée ou déplacée, vous devez la définir comme une référence de cellule absolue en écrivant $A$1.


La fonctionnalité de référence absolue est particulièrement utile lorsque vous écrivez des formules qui doivent rester identiques, même si vous les copiez ou les déplacez dans d'autres cellules. Cela peut être utile lorsque vous utilisez des valeurs fixes, telles que des taux de TVA.


En utilisant la référence absolue, vous pouvez également combiner des références relatives et absolues dans une même formule. Par exemple, si vous avez une formule qui fait référence à la cellule A1 et que vous voulez que la colonne reste la même, mais que la ligne change, vous pouvez utiliser une référence mixte en écrivant $A1.


Dans notre question, la formule est en référence absolue. Rien ne va bouger avec un glisser copier.

Réponse : 20%




Question 8 : Monsieur X a protégé sa feuille par un mot de passe et l'ensemble des cellules de cette feuille sont verrouillées. Pourtant, Monsieur Y a pu modifier la cellule de couleur verte. Comment cela est-il possible ?


Le verrouillage de cellule dans Excel vous permet de protéger des cellules ou des plages de cellules spécifiques dans une feuille de calcul afin qu'elles ne puissent pas être modifiées accidentellement ou intentionnellement. Vous pouvez utiliser cette fonctionnalité pour protéger des cellules contenant des données importantes ou des formules complexes.


Il y a deux façon de verouiller les cellules sur une feuille Excel.

La première est plutôt connu :

  1. Sélectionnez la ou les cellules que vous souhaitez verrouiller.

  2. Cliquez avec le bouton droit de la souris sur la sélection et choisissez "Format de cellule".

  3. Dans la boîte de dialogue "Format de cellule", cliquez sur l'onglet "Protection".

  4. Cochez la case "Verrouillée" pour empêcher la modification de la cellule.

  5. Cliquez sur OK pour fermer la boîte de dialogue "Format de cellule".

La deuxième est la méthode que nous avons indiquée en réponse


Réponse : Mr X a dû inclure des plages modifiables même si la cellule est verrouillée avec l'"Autoriser la modification des plages" et il a sélectionné la cellule verte



En résumé :


Ce sujet est vaste et très important, car la plupart des personnes n'arrivent pas à maitriser les fonctions logiques et ignorent les mises en forme sous tableau et ces nombreux atouts.

Ceci n'est que la première partie du niveau intermédiaire sous Excel (mais la partie la plus importante).

Nous espérons que ce test vous a été profitable pour connaitre votre niveau.




bottom of page